Saturday, February 02, 2008

Failed dependencies Message (glibc, libaio, /bin/sh) Installing Oracle XE on Ubuntu

I downloaded the RPM for Oracle XE for Linux and tried to install it without success. Here is my result:
medined@bashi:~/Desktop$ sudo rpm -ivh oracle-xe-10.2.0.1-1.0.i386.rpm
error: Failed dependencies:
        glibc >= 2.3.2 is needed by oracle-xe-10.2.0.1-1.0.i386
        libaio >= 0.3.96 is needed by oracle-xe-10.2.0.1-1.0.i386
        /bin/sh is needed by oracle-xe-10.2.0.1-1.0.i386
I did some research but could not find a way to update glibc. However, I did run into an apt-get repository mentioned at http://www.oracle.com/technology/tech/linux/install/xe-on-kubuntu.html. I followed the instructions on that page and had Oracle working within minutes.
Post a Comment